Ao utilizar uma API mais recentes (API level 23) com suporte a API’s mais antigas (API Level 15), temos um pequeno problema ao tentarmos alterar o background de forma programável.

“Call requires API level 23 (current min is 15)…”

Para resolver este problema, o Android oferece o ContextCompat: